Welcome to Typemock Answers. Here you can ask and receive answers from other community members. And if you liked or disliked an answer or thread: react with an up- or downvote Enjoy!

SmartRunner Run Test button resulting in output "TestRunner: Unknown Test timed out"

0 votes
With Isolator 8.0.5.2, VS2013 Update 5, TestDriven.Net 3.8 Beta 2, NUnit 2.6.4, Windows 7 64-bit, when I click Run Test on this empty unit test inside of an x64 C# unit test project:
 
 
Text "Unexpected error while running tests." appears in Test Navigator, and when clicked, the Typemock output window displays this:
 
TestRunner: Unknown Test timed out
TestRunner: Unknown Test timed out
TestRunner: Unknown Test timed out
TestRunner Error: TestRunner crashed trying to run test: ClassTests.Test [Pending]
 
On the same blank unit test, command TestDriven.NET.RunTests results in this output:
 
------ Test started: Assembly: CSharpBench.Test.dll ------
 
1 passed, 0 failed, 0 skipped, took 1.39 seconds (NUnit 2.6.4).
 
My Isolator settings:
 
 
 
Any ideas on how to fix this?

 

asked Apr 21, 2015 by NeilJustice (1,110 points)

1 Answer

0 votes
Thank you for the detailed report.

The reason for this error is that "SmartRunner Process timeout(in seconds)" field defined as "0", which means that it doesn't have any timeout.

In order to restore it to the default value(300) delete the value and press OK, or change it to "300".

We will fix it in our next release.

Let us know if it helps.

 

Bar David | Support Team

answered Apr 21, 2015 by Bar (3,540 points)
Of course! Embarrassment! Thanks Bar.
...