chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes
I install Typemock 7.5.6 on Windows XP SP3 with VS2010 SP1. At first I try to run the Typemock examples, which failed. To analyse the error, I enable the logging and run only one Test. See the attached file. Both, Windows XP and VS2010 are German.
A test on Windows Server 2008R2 with VS2010 SP1 was successfully.

TestRunner crashed-logs-20141030.zip
asked by rbrunken (3.1k points)

3 Answers

0 votes
Hi,
We are looking into it,
I'll keep you posted as soon as possible.
answered by Bar (3.6k points)
0 votes
Hi,

We didn't manage to reproduce the issue.

Typemock.Common.TestsRunner.exe is the endpoint of the pipe (See the log devenv-extension) which can't be found.
I'd like to make sure that this process is running by caching it between tests runs.
In order to do that please Open Typemock menu in Visual Studio ->Options->Visual Studio tab, check "Use cached test runner process" and press apply.

Configure windows to create aCrush Dump.
Now try to run tests, and make sure that Typemock.Common.TestsRunner.exe is running with "Task Manager"\"Process Explorer".
If the process is down when you're trying to run the tests, check if there is a crush dump record of this and send it to us.
answered by Bar (3.6k points)
0 votes
Hi,
I configure my system for the CoreDump, but the CoreDump was not created. I have install VS2010SP1 without later HotFixes, because this system is not connected to the internet. Is it possible that TypeMock Isolator require some HotFixes?

In the eventlog i saw this error: "VSTTExecution". See the attached file for detail information.

Microsoft.VisualStudio.QualityTools.CodedUITestPackage not found.txt
answered by rbrunken (3.1k points)
...