chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Community! Here you can ask and receive answers from other community members. If you liked or disliked an answer or thread: react with an up- or downvote.
0 votes
Hi,

I have TypeMock Isolator 7.0.7 installed with AutoRunner and TestLint (TestLint is disabled in ExtensionManager). When I enable AutoRunner and it's running in the background, I receive the error below displayed in the Output window.

I am running Win7 x64 SP1 with VisualStudio 2010 SP1 (run as Administrator).
START: Scan
END  : 00:00:00.2492247
START: Analyzing test projects
END  : 00:00:01.2671211
START: Loading solution tests information
END  : 00:00:00.0169343
START: UpdateAssembliesWhiteList
END  : 00:00:00.0503583
START: GetAllTests
END  : 00:00:00.0000150
START: Executing tests
Failed killing daemon: System.ComponentModel.Win32Exception (0x80004005): Access is denied
   at System.Diagnostics.Process.Kill()
   at Typemock.Common.Core.DaemonNUnitRunner.KillDaemon(Process process)
Failed killing daemon: System.ComponentModel.Win32Exception (0x80004005): Access is denied
   at System.Diagnostics.Process.Kill()
   at Typemock.Common.Core.DaemonNUnitRunner.KillDaemon(Process process)
Test run failed more than 1 times - aborting
Test run failed more than 1 times - aborting
System.ServiceModel.CommunicationException: There was an error reading from the pipe: The pipe has been ended. (109, 0x6d). ---> System.IO.PipeException: There was an error reading from the pipe: The pipe has been ended. (109, 0x6d).
   at System.ServiceModel.Channels.PipeConnection.FinishSyncRead(Boolean traceExceptionsAsErrors)
   at System.ServiceModel.Channels.PipeConnection.Read(Byte[] buffer, Int32 offset, Int32 size, TimeSpan timeout)
   --- End of inner exception stack trace ---

Server stack trace: 
   at System.ServiceModel.Channels.PipeConnection.Read(Byte[] buffer, Int32 offset, Int32 size, TimeSpan timeout)
   at System.ServiceModel.Channels.DelegatingConnection.Read(Byte[] buffer, Int32 offset, Int32 size, TimeSpan timeout)
   at System.ServiceModel.Channels.SessionConnectionReader.Receive(TimeSpan timeout)
   at System.ServiceModel.Channels.SynchronizedMessageSource.Receive(TimeSpan timeout)
   at System.ServiceModel.Channels.FramingDuplexSessionChannel.Receive(TimeSpan timeout)
   at System.ServiceModel.Channels.FramingDuplexSessionChannel.TryReceive(TimeSpan timeout, Message& message)
   at System.ServiceModel.Dispatcher.DuplexChannelBinder.Request(Message message, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
   at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]: 
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at Typemock.Common.Core.ITestRunnerService.RunTests(List`1 assemblies, List`1 testNames, String sessionID, Dictionary`2 testsOptions)
   at Typemock.Common.Core.TestRunnerServiceSynched.RunTests(List`1 assemblies, List`1 testNames, String sessionID, Dictionary`2 testsOptions)
   at Typemock.Common.Core.DaemonNUnitRunner.PerformRunTests(List`1 testsAssemblies, IEnumerable`1 testNames, Guid sessionGuid, Dictionary`2 testOptions)
   at Typemock.Common.Core.DaemonNUnitRunner.<>c__DisplayClass5.<TryRunTests>b__0()
END  : 00:01:14.3289278
START: Loading test results
END  : 00:00:00.0060379
Test run results - 
unexpected error when trying to run test: VCI.Enterprise.AccountProcessing.Tests.SilverPopHelperTest.ShouldSendEmail
unexpected error when trying to run test: VCI.Enterprise.AccountProcessing.Tests.SilverPopRepositoryWrapperTest.SendTransactEmail_Should_Not_Throw_Exception_When_UpdateType_Is_Not_Correct
unexpected error when trying to run test: VCI.Enterprise.AccountProcessing.Tests.VciCreateAccountPayoffQuoteModuleTest.CreateMessageRequestForPayoffQuote
unexpected error when trying to run test: VCI.Enterprise.AccountProcessing.Tests.VciCreateAccountPayoffQuoteModuleTest.CheckIfPayoffCreateRequestIsValid_Test
...
...
asked by (8.4k points)

62 Answers

0 votes
Hi Teena,

Hope you got Alex's email.
We are now trying to find a work around for this issue And will update you as soon as we have one.
answered by (4k points)
0 votes
Can I have an update as well since I started the Thread?

(or just post a message in this thread saying the bug has been fixed). Thanks.
answered by (8.4k points)
0 votes
Hi Dave and Teena,

The error message described above is a product of Isolator not being able to load two app.config files under one solution, and since Isolator has it's own app.config it won't load the app.config of your program.

This feature is to be added to the Isolator in the future.

A workaround for this issue is to copy the content of your app.config to Isolator's app.config.

Please let me know if it helps.
answered by (18k points)
0 votes
Hi Alex,

Can you please let us know the path for the isolater's app.config, where we need to add our entries?
Also please share the steps it will be really helpful.

Thanks & Regards
Teena Sharma
answered by (1.4k points)
0 votes
Hi,

Sorry for being short on details.

The Isolator app.config files are:
Typemock.Common.TestsRunner.exe.config
Typemock.Common.TestsRunner-x86.exe.config

Depends on your environment.

You can find them under:

"...\Isolator\7.1\SmartRunner\Typemock.Common.TestsRunner-x86.exe.config"

There is only one step and it is to merge the both app.configs(ours and yours) into one of the files above.


This is only a temporary workaround.
The feature of supporting multiple app.configs will be added in the future versions.

Please let me know if helps.
answered by (18k points)
0 votes
Hi Alex,

I tried the approach to add my web.config entries into the isolator's app.config files given below as suggested by you:

Typemock.Common.TestsRunner.exe.config
Typemock.Common.TestsRunner-x86.exe.config

But still it is giving below errors:
unexpected error when trying to run test: TestUnitProject.Class1Test.GetListItemsFromHiddenPropertyListTest
unexpected error when trying to run test: TestUnitProject.Class1Test.GetListFromHiddenPropertyListTest


Can you please try to solve the issue for the test project i have shared with you previously(its attached in one of my replies in this forum).
In that project app.config only contains the below entry:
<connectionStrings>
<add name="MyProjectUnitTestData" connectionString="Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\TestData.xls;Extended Properties=Excel 8.0;"
providerName="System.Data.OleDb" />
</connectionStrings>

and i have moved same to the isolator's app.config and the above error is getting logged as output for autorunner.

Please spare sometime to look into this as if the issue will be resolved for the this test project the same fix will get applied to my original project.

Looking forward to hear on this further asap.

Thanks & Regards
Teena Sharma
answered by (1.4k points)
0 votes
Hi Alex,

I tried the approach suggested by you but it did not seems working in my senario.
I have created a demo project containing simple C# code in it.Please find the attachment for same.

The unit test passes if i run it without Auto runner feature enabled. otherwise with Autorunner its giving the same issue.

Please look into it and let me know if you need any other information on same.

Thanks & Regards
Teena Sharma

UnittestProj.zip
answered by (1.4k points)
0 votes
Hi Alex,

Did you get chance to look into the shared project? This project is not dependant on the sharepoint and enterprise library so you will be able to run this directly on your machine too.

Please let me know the updates on this.

Thanks & Regards
Teena Sharma
answered by (1.4k points)
0 votes
Hi Teena,

Thank you for the project.

I'm now working on it, I will update you ASAP.
answered by (18k points)
0 votes
Hi Teena,

We are now trying to reproduce this problem using the project you sent.
Can you please copy the error you're getting while running the test?
answered by (4k points)
...