chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Answers. Here you can ask and receive answers from other community members. And if you liked or disliked an answer or thread: react with an up- or downvote Enjoy!
0 votes
I am using TypeMock v 4.3.1.0 and Visual Studio 2008.

I installed the 32 bit version, and I began using it in some of my unit tests. However, when I try to run the unit tests, TypeMock complains to me saying that TypeMock isn't enabled with VS. Here is the error message I get:

Error Message:
Initialization method Company.App.UnitTest.CollatorTest.MyTestInitialize threw exception. TypeMock.TypeMockException: TypeMock.TypeMockException:
*** Typemock Isolator is not currently enabled.
To enable do one of the following:

* To run Typemock Isolator as part of an automated process you can:
- run tests via TMockRunner.exe command line tool
- use 'TypeMockStart' tasks for MSBuild or NAnt

* To work with Typemock Isolator inside Visual Studio.NET:
set Tools->Enable Typemock Isolator from within Visual Studio

For more information consult the documentation (see 'Running' topic).


However, I checked the Tools menu and it says "Disable TypeMock Isolator", so I'm assuming that means that TypeMock is enabled on VS. I try to disable TypeMock integration, run the test, I get the same error. When I enable TypeMock integration, run the test, I get the same error. I'm not sure what's going on or how to resolve this issue.
asked by (640 points)

3 Answers

0 votes
In addition, I noticed that my project is a Web Site project. Have you noticed any quirks with TypeMock and VS web site projects?

It was also a VS 2005 web site to begin with and was converted to a 2008 project.
answered by (640 points)
0 votes
Hi,

It does sound strange.
I'd start with a re-install. Uninstall first, then reinstall (preferably 4.3.2 and more so 5.0). You can download both from here

Let me know how it goes.
answered by (14.5k points)
0 votes
Hi,

Have you made progress on this?

Thanks,
answered by (14.5k points)
...