chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Answers. Here you can ask and receive answers from other community members. And if you liked or disliked an answer or thread: react with an up- or downvote Enjoy!
0 votes
Hi,

I have a windows 7 64 bit computer and I'm trying to run a test in visual studio 2010 using typemock and I get the following exception when running the test ( using the run button at the test results window):

[Test method iPCBLAdaptorTest.iPCBLAdaptorUnitTest.TestA threw exception:
TypeMock.TypeMockException:
*** Typemock Isolator is not currently enabled.
To enable do one of the following:

* To run Typemock Isolator as part of an automated process you can:
- run tests via TMockRunner.exe command line tool
- use 'TypeMockStart' tasks for MSBuild or NAnt

* To work with Typemock Isolator inside Visual Studio.NET:
set Tools->Enable Typemock Isolator from within Visual Studio

For more information consult the documentation (see 'Running' topic)


When I debug the test, no exception is thrown.....only when running it.

I'm using the typemock in CLI/C++ code( managed C++).

Can you please help?

Thanks.
I
asked by (640 points)

7 Answers

0 votes
Hi,

Isolator requires certain environment variables to be set in order to work properly. When running from Visual Studio they are set by the Isolator addin - can you double check that Isolator is enabled under the Typemock menu?

If this doesn't work we should probably do an online session to figure this out. Let me know if you had any luck.

Doron
Typemock Support
answered by (16.5k points)
0 votes
Hi,

Under the typemock menu I have the option of disabling the typemock Isolator, so I guess it is enabled....

I guess we will need to do an online session since nothing I tried so far has worked.

Thanks,
Asi
answered by (640 points)
0 votes
Hi Doron,

i suggest setting up an online session,
simple things like uninstall and install didnt work, I also tried to manually register the 64 bit and 32 bit dll's into the registry which also didnt help.

funny thing is that the tests are running fine under debug mode, and fail on a simple run.
answered by (6.6k points)
0 votes
Hi guys,

I'm very sorry for the delayed response.

If this is still a relevant issue, I'd like to handle it ASAP. Asi, I will contact you shortly via our support system, so that we can schedule an online meeting and solve this problem!

Thanks.
answered by (5.7k points)
0 votes
Hi
i am also facing the same issue with Typemock 6.2.
In debug all works fine , but in regular run i get :
Test method Taurus.Server.Dal.Test.ExecutionDefinitionDalTest.LoadFlowByIdTest threw exception:
TypeMock.TypeMockException:
*** Typemock Isolator is not currently enabled.
To enable do one of the following:

* To run Typemock Isolator as part of an automated process you can:
- run tests via TMockRunner.exe command line tool
- use 'TypeMockStart' tasks for MSBuild or NAnt

* To work with Typemock Isolator inside Visual Studio.NET:
set Tools->Enable Typemock Isolator from within Visual Studio

For more information consult the documentation (see 'Running' topic)

is there any solution for this issue ?
Oren
answered by (3.2k points)
0 votes
Hi Oren,
I have taken this offline (emails) to solve your problem.
answered by (32k points)
0 votes
This was solved after some non related reboots :o
answered by (32k points)
...