chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes
Hi,
 
I am running VS2015 Update 1 with typemock 8.3.107 and also Resharper 10.
I have a project that uses typemock and whenever I try to debug from VS it I get the error below.
Runner is enabled, so is integrate with other Runners.
Tried to disable/re-enable - nothing...
Thanks,
Moshe
 
'Isolate.Fake.Instance<ILogger>()' threw an exception of type 'TypeMock.TypeMockException'
    Data: {System.Collections.ListDictionaryInternal}
    HResult: -2146233088
    HelpLink: null
    InnerException: null
    Message: "\r\n*** Typemock Isolator is currently disabled. Enable using the following:\r\n\r\n * Within Visual Studio: \r\n   - Use Typemock Smart Runner  \r\n   - For other runners, Choose Typemock Menu and click \"Integrate with Other Runners\"\r\n \r\n * To run Typemock Isolator as part of an automated process you can:\r\n    - run tests via TMockRunner.exe command line tool\r\n    - use 'TypeMockStart' tasks for MSBuild or NAnt\r\n \r\nFor more information consult the documentation (see 'Running Unit Tests in an Automated Build')"
    Source: "TypeMock"
    StackTrace: "   at TypeMock.InterceptorsWrapper.VerifyInterceptorsIsLoaded()\r\n   at _o5NtKPKBqjpK2bca2sSrdbWge9t_._oEVqK2sNvaVRxKTchvwFj5JouMq_._vEe0Eg4rD42QZEmXdUs2Gqo0EQC_()\r\n   at TypeMock.MockManager.Init(Boolean collectAllCalls)\r\n   at TypeMock.MockManager.Init()\r\n   at _3qYkTLMWTAlbjHapXrg376QjqFI_._LdOrBrli6Ihgi9rHoQihjJtkBCi_._8P6OirTYMwcdVWOmCbp00BddeWc_[\u0001](Members , Constructor , Constructor , Type , Object[] )\r\n   at _3qYkTLMWTAlbjHapXrg376QjqFI_._LdOrBrli6Ihgi9rHoQihjJtkBCi_.Instance[T](Members behavior)\r\n   at _3qYkTLMWTAlbjHapXrg376QjqFI_._LdOrBrli6Ihgi9rHoQihjJtkBCi_.Instance[T]()"
    TargetSite: {Void VerifyInterceptorsIsLoaded()}
asked by (1.1k points)

1 Answer

0 votes
Hi Moshe,

How you debug it?

Turn on SmartRunner logs, restart Visual Studio and debug again.

And send, please, this logs here, or better to typemock@support.com

Cheers,

Eva
answered by (1.6k points)
...