chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Community! Here you can ask and receive answers from other community members. If you liked or disliked an answer or thread: react with an up- or downvote.
0 votes
Install VS2010 beta2 on windows server 2008 SP2 64bit
Install TypemockIsolator2010Setup600

Create a project and right click to select run code analysis

Result:
fxcopcmd.exe hangs.

This is caused by the process runs as STA instead of MTA thread mode.
The issue does not happen without typemock integrated.
An easy test is to run the following code in a console app by pressing control+F5, the result is STA.
If you press F5, it shows MTA.

class Program
{
[MTAThread()]
static void Main(string[] args)
{
Console.WriteLine(System.Threading.Thread.CurrentThread.ApartmentState.ToString());
}
}
asked by (680 points)

8 Answers

0 votes
Try disabling Typemock productivity from Tools -> add-in manager.
answered by (11.9k points)
0 votes
Issue remains after Typemock Productivity is disabled.
Issue is gone after the TypeMock Isolator is disabled.

Attached is some debug info from VS dev. Please make a fix in the next release.

Typemock’s dll is calling CoInitialize and initializes it to STA
ChildEBP RetAddr Args to Child
WARNING: Stack unwind information not available. Following frames may be wrong.
0028f444 1000837e 00000000 fffffffe 77c936fa ole32!CoInitialize
0028f4c4 11004e25 01fe2e18 02021278 00000001 MockWeaver!DllGetClassObject+0x70de
0028f4f4 77c8e20c 00000000 002bb670 002bb670 ProfileLinker!DllRegisterServer+0x36f5
00000000 00000000 00000000 00000000 00000000 ntdll!RtlInitUnicodeString+0x164
answered by (680 points)
0 votes
I will forward this bug report and we'll fix this issue in a future version of Isolator

Of course I will update this thread after this issue will be resolved
answered by (11.9k points)
0 votes
This has been a bug in our profiler implementation, and with Microsoft's help we were able to fix it. I sent a patched version to William, and this will be a part of the next Isolator version.

Doron
Typemock Support
answered by (16.5k points)
0 votes
The patch fixed the problem. thanks for quick response.

William
answered by (680 points)
0 votes
Doron,

Is there a chance that this fix also address the problem with hanging (in build and with TestDriven.NET) that I reported earlier? Or it is irrelevant?
answered by (19.4k points)
0 votes
No - we are working hard on fixing that issue, and we've had good progress thanks to the data you and others provided. We'll send over a patch once it's fixed.

Doron
answered by (16.5k points)
0 votes
No - we are working hard on fixing that issue, and we've had good progress thanks to the data you and others provided. We'll send over a patch once it's fixed.

Doron


Good to hear! Looking forward for this.

Vagif
answered by (19.4k points)
...