Welcome to Typemock Answers. Here you can ask and receive answers from other community members. And if you liked or disliked an answer or thread: react with an up- or downvote Enjoy!

Cannot see the add-in in VS2005

+1 vote
I have installed TypeMockSetup352.msi, but the add-in does not show in Visual Studio. I have admin rights and the only way to run the tests is using tmockrunner from the commandline. Even running the mocking_on.bat file has no affect.

I can see it has installed to "C:\Documents and Settings\All Users\Application Data\Microsoft\VisualStudio\8.0\Addins". Is there somewhere else it needs to be as my testdriven.net add-in works fine but isn't at the above location (Maybe there is another way)???

My ideal situation would be to be able to run all tests from the testdriven.net add-in (Right-click > RunTests) while using typemock.

I really like the fact you can mock classes and not just interfaces. We have a lot of legacy code so it fits perfectly, but I dont want to run nunit gui or any command line tool as we want testing to be as seamless as possible and have quite a few projects

Any help?

Lance
asked Aug 29, 2006 by lancej (790 points)

20 Answers

0 votes
Please check if you have both these files in the Add-in directory:
TypeMock.AddIn2005.AddIn
TypeMock.AddIn2005.dll

if you have TypeMock.AddIn2005.AddIn_ rename it to TypeMock.AddIn2005.AddIn

Within Visual Studio Click Tools->Add-in Manager and Click on TypeMock.NET

We use TestDriven and TypeMock together just as you have described
answered Aug 29, 2006 by scott (29,080 points)
+1 vote
It is all there in the directory but just doesn't appear at all in the add-in manager dialog.
Does it work with Visual studio Professional as that is what we have?
I do have full admin rights and testdriven.net works fine.
Perhaps TD.net is still using the old 1.1 registration technique. Do you have a version that uses this way of registation, just to see if that is the problem?

I will still try and find a solution as going through the console is a pain


Thanks anyway
answered Aug 30, 2006 by lancej (790 points)
+1 vote
There is certainly a problem with Visual studio. I can't event add a test add-in that I create.
answered Aug 30, 2006 by lancej (790 points)
+1 vote
I know Visual Studio is reading the Addin file as I can easily place an error inside it so VS will display a error message box.
If I havent tampered with the addin file VS just doesn't want to display the addin in the addin manager. gggrrrr
answered Aug 30, 2006 by lancej (790 points)
+1 vote
Typemock was installed on a machine with VS2003 and VS2005 in it. The addin appeared in VS2003 but not in VS2005. My machine does not have VS2003 on it and still VS2005 still doesnt show the addin.
Not sure if it is significant, but it seems VS2005 just doesnt like me :(
answered Aug 30, 2006 by lancej (790 points)
0 votes
I guess that the VS doesn't like us :-(

Lets try resetting it.
Try:
> devenv /ResetSkipPkgs
if that doesn't work try
> devenv /Log and see the log file.
answered Aug 30, 2006 by scott (29,080 points)
+1 vote
Neither has worked. The log isn't much of a log.
All I know is that testdriven.net installs the plugin differently. There are registry entries and no .addin for testdriven and it seems to still work. Perhaps if you have time you can try and install it the same way?

If this works however it will change how we do testing, since we have a lot of legacy code. It really grinds me that to get nmock to work I have to fudge the main code line so I would really like to work with typemock.
Good luck

Lance
answered Aug 31, 2006 by lancej (790 points)
0 votes
Hi,
We are looking into that issue.

In any case could you please copy the 2 files to:
My Documents\Visual Studio 2005\Addins\
answered Aug 31, 2006 by scott (29,080 points)
+1 vote
Still no luck. I suspect there is something wrong with VS2005, possible either the configuration I have or the actual Professional version. Have you guys tried it out on a Professional version yet?

Any way, I have come up with the next best thing. I have a batch file that I can access by adding it as an external tool. This runs the tmockrunner with nunitgui. At least I am able to test one method at a time this way and I can have the gui always up. Downside I probably won't be able to debug my tests. It doen't happen very often so I am not worried about that.

After seriously using typemock yesterday, I am very impressed as I can get the code to look the way I want it and not the the limitations of testing to dictate it. I understand the need for naturalmocks especially with refactoring and I will see what I can do in getting the full version.

So far it is superior to nmock in every way I use it. Although I did run into the need to mock one class in mscorlib. :D

Well done.

Lance
answered Sep 1, 2006 by lancej (790 points)
0 votes
Lance,
The workaround will work, but I really want to solve the problem.

We test that TypeMock works on the Professional version, so I guess that it is something else.

Please send me your Visual Studio Configuration. Here is how:
:arrow: In Visual Studio->Help->About Visual Studio->Click Copy Info
Then paste it into a post

:?: As we are currently developing the mscorlib mocks, could you tell me what class you needed to mock.
answered Sep 1, 2006 by scott (29,080 points)
...