chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Answers. Here you can ask and receive answers from other community members. And if you liked or disliked an answer or thread: react with an up- or downvote Enjoy!

Issue running coverage with VS runner

0 votes
Hello Bar,
 
Could you please help me with this error:
 
Test Name: TestOnActionExecutingWithCultureEmptyAndCookieNotNull
Test FullName: Web3.Tests.Attributes.LocalizationAttributeTest.TestOnActionExecutingWithCultureEmptyAndCookieNotNull
Test Source: c:UsersAdminSourceWorkspacesWeb3Web3Web3.TestsAttributesLocalizationAttributeTest.cs : line 63
Test Outcome: Failed
Test Duration: 0:00:00.085

Result Message:
SetUp : TypeMock.TypeMockException :
*** Unknown profiler is enabled please contanct typemock@support.com with the flowing data: unknown profiler clsid = {44250666-1751-4368-a29c-31caf4ccf3f5}
Result StackTrace:
at TypeMock.InterceptorsWrapper.VerifyInterceptorsIsLoaded()
at gb.e()
at TypeMock.MockManager.Init(Boolean collectAllCalls)
at TypeMock.MockManager.Init()
at gm.CreateFakeInstance[T](Members behavior, Constructor constructorFlag, Constructor baseConstructorFlag, Type baseType, Object[] ctorArgs)
at gm.Instance[T](Members behavior)
at Web3.Tests.Attributes.LocalizationAttributeTest.SetUp() in c:UsersAdminSourceWorkspacesWeb3Web3Web3.TestsAttributesLocalizationAttributeTest.cs:line 28

 

I have the Enable Mocking for 3rd party runners enable and I have this issue.
 
I got this same error in 62 tests from 135 when in run coverage in VS runner.
 
Thanks
asked Jan 19, 2015 by danielVeinti0809 (6,190 points)

Taking it offline

2 Answers

0 votes
It looks like you are using INtellitrace.
Please turn off INtellitrace and then run the tests.
Let me know if it helps.
 
answered Jan 20, 2015 by Bar (3,560 points)
edited Jan 21, 2015 by Bar
0 votes

Hello Bar,

 

I'm using Visual Studio Premium 2013, i don't have Intellitrace installed, i didn't see the Intellitrace option in Options menu according to this suggestion to disable intellitrace:
 

http://msdn.microsoft.com/en-us/library/dd264948(v=vs.100).aspx

 

Do you have any other clue?

 

Thanks

answered Jan 20, 2015 by danielVeinti0809 (6,190 points)
...