chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes
Hi there,

I've installed Visual Studio 2013, Update 1 and then installed Typemock 7.4.3.0 and while I can create tests using Typemock, I don't get the Typemock Test Navigator and its functionality of running tests after every compilation.

Am I doing something wrong, or is there an incompatible setting or something?

Thanks,

jack
asked by (18.4k points)

5 Answers

0 votes
Hi Jack,

I would ask you to check 3 things :
1. In VS go to Typemock menu -> Windows -> Test Navigator
It should get you to the Test Navigator window automatically.
2. Go to Tools -> Extensions & Updates -> Make sure Typemock test runner is enabled.
3. Go to Typemock menu -> enable "Run Fast Pending Tests After Build"

Please let me know if any of those helped.
answered by (1.5k points)
0 votes
Thank you, Shai. The problem was #2. The test runner was disabled.

Jack
answered by (18.4k points)
0 votes
What happens if the Typemock test runner doesn't show up in Tools and Extensions? Is there something else you have to do to make it show up here, or another way to enable it?
answered by (18.4k points)
0 votes
Hi Jack,

Please do the following steps:
1) In VS Menu -> Go to Tools -> Extension Manager -> Check if TypeMock Smart-Runner is on the list
if not do no.2
2) Re-Install Isolator

Please let me know if that worked.
answered by (1.5k points)
0 votes
Hi Jack,

have you manage to use the Smart Runner ?

Let me know if you need any help.
answered by (1.5k points)
...