chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Answers. Here you can ask and receive answers from other community members. And if you liked or disliked an answer or thread: react with an up- or downvote Enjoy!

Tests in 6.2.2 and 7.3 on TFS 2010 Build Server

0 votes
We have several projects that use Isolator 6.2.2. The tests run as part of our TFS build. We did not do anything special to enable this except install Isolator on the build server. All was good.

We have new projects that are starting up that are using VS2012 and .NET 4.5. We had the same problems others have reported using the older version of Isolator, so we have upgraded those projects to Isolator 7.3.0.

I am having problems getting both types of projects to run on the build server. For the 7.3.0 projects I am using the AutoDeploy method outlined in your documentation. This works -- the builds run and the tests pass.

But now when I set up an AutoDeploy folder for a 6.2.2 project and try to use the same build template (DefaultTemplateWithTypemock.xaml that shipped with 7.3.0) the build fails with the error:
Type 'TypeMock.CLI.Common.TypeMockRegisterInfo' in assembly 'TypeMock.CLI.Common, Version=6.2.2.0, Culture=neutral, PublicKeyToken=null' is not marked as serializable.

What is the preferred method for getting 6.2.2 projects to work on a TFS 2010 build server along with 7.3.0 projects?
asked Feb 27, 2013 by BruceWright18 (3,100 points)

1 Answer

0 votes
Hi Bruce,

Please make sure that the AutoDeploy folder contains the DLLs of version 6.2.2.

Looking forward to your feedback.
answered Mar 6, 2013 by alex (17,950 points)
...