chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Answers. Here you can ask and receive answers from other community members. And if you liked or disliked an answer or thread: react with an up- or downvote Enjoy!
0 votes
My team upgraded to VS 2010 RTM and .NET 4.0 recently. Since doing so, I have not been able to execute any tests using the R# unit test runner. I'm presented with a dialog box stating the following.

Unit Test Runner failed to load test assembly:
JetBrains.ReSharper.TaskRunnerFramework.TaskException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.


In a sample unit test project that contains a simple class and a unit test fixture and has no reference to TypeMock asseblies, if I disable TypeMock Isolator the test runs successfully. When I enable Isolator, the test fails.

I'm running:

    Windows 7 Ultimate x64 (but failure occurs when project compiled as ANY CPU or x86)VS 2010 Version 10.0.30319.1 RTMRelIsolater 6.0.0.0JetBrains ReSharper 5 C# Edition - Build 5.0.1659.36 on 2010-04-13T02:19:06NUnit 2.5.3
asked by (3k points)

2 Answers

0 votes
Hi Ron,

We've fixed an issue we had with R# & VS2010 on version 6.0.1 I suggest you try the newest version of Isolator (6.0.2) and see if the issue still occurs.
answered by (11.9k points)
0 votes
Isolator v6.0.2 resolved the issue. It also solved another problem I was having where I could not run tests in assemblies compiled with ANY CPU on an x64 machine. Previously, I had to compile w/ x86 in order to run them.

Thanks for the response.
answered by (3k points)
...