chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Answers. Here you can ask and receive answers from other community members. And if you liked or disliked an answer or thread: react with an up- or downvote Enjoy!
0 votes
After upgrade while I run command Tools.Typemock Isolator Configuration... I get the message box TypeMock Problem "Please send the following error to Typemock Support:Found invalid data while decoding. at c9.a(String A_0)
at c9.r()
at TypeMock.Runner.ConfigurationForm.a(String A_0, String A_1)
at TypeMock.Runner.ConfigurationForm..ctor()
at a0.a(String[] A_0)
I tried to completely remove old installations and run setup again, but the problem still exists.
________
Daimler Majestic
asked by (680 points)

7 Answers

0 votes
Hi Ander,

Are you logged in as a local administrator? Are you running VS under administrator privileges?

Thanks,
Doron,
Typemock support
answered by (16.5k points)
0 votes
Hi Doron,

Yes, I'm logging as a local administrator on my Windows 2003 Server and running VS 2008 with administrative privileges. I had used licensed Typemock + TestDriven.NET 2.8 Personal + NUnit-Net-2.0 2.2.9.

Please inform me if you need more detailed info.

Ander.
________
J. Edward Lundy
answered by (680 points)
0 votes
Hi ander,

A couple more questions: What version did you have before, and which version are you installing now? Also is it a 64 bit installation?

And finally: Can you run the configuration program from outside VS? (All Programs->Typemock->Isolator 5.x->Isolator Configuration).

Thanks,
answered by (14.5k points)
0 votes
Hi Gil,

As I wrote in a topic, I had Typemock Isolator 4.3.1.0 before. Then I tried to install 5.1. When I got error, I tried to remove old installation and install 5.0, but the error appered again.

All these are 32 bit installations. Running All Programs->Typemock->Isolator 5.x->Isolator Configuration leads to error too.

Just now I correct the sitiation. I uninstall Typemock, remove registry key [HKEY_LOCAL_MACHINE\SOFTWARE\TypeMock] and install 5.1 again. Configuration dialog works! It seems, name of company is in capital letters now.

Thanks,
Ander.

P.S. If you have any questions, please send me e-Mail.
________
Saratoga
answered by (680 points)
0 votes
Hi Ander,

Glad you worked this out.
There is a bug somewhere, in the upgrade. Something in the environment that we didn't catch during the installation. We'll try to reproduce it here. Thanks for your offer, we might take you up on it.
answered by (14.5k points)
0 votes
I had the same problem, and the only resolution was also to remove the registry key. Then the company name was registered in uppercase letters.
answered by (19.4k points)
0 votes
Thanks for the tip, Vagif, I'll have another look at the upgrade scenario in relation to the registry key change.
Doron
Typemock support
answered by (16.5k points)
...