chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes

I m writing unit tests for legacy code with Typemock. I have done following steps

Adding "Isolator.h" according to Documentation:
Right-click on Project->Properties-> C++:
Go to and choose "C:Program Files (x86) TypemockIsolator++includeForTests  (or where Isolator is located).
then Linker->Input- > 
"C:Program Files (x86)TypemockIsolator++indIsolatorCore.lib" (Or where the lib of x64 is located).
Then Build Events->Post-Build Events ->
copy "C:Program Files (x86)TypemockIsolator++indIsolatorCore.dll" "$(TargetDir)"
I m using x64 lib files. It builds successfully. But at runtime i get this error in output window "Could not find msdia140.dll in the PATH, please add the file to the search path." So I added the msdia140.dll to output folder. But still I get this error. Any idea how to fix this. 
asked by abhijithk (1.7k points)

1 Answer

0 votes
 
Best answer

Hi,

Sorry for the misunderstanding, we are now noticing that the right way to set up a unit test project is not written correctly in our documentation.
Please do the following, First delete the Isolator++ Cache file.
Then add this lines in the Post Build Events:
copy "$(InstallationDir)inIsolatorCore.dll" "$(TargetDir)"
copy "$(InstallationDir)inmsdia140.dll" "$(TargetDir)"
copy $(InstallationDir)insymsrv.dll" "$(TargetDir)"

Of course the Installation dir is the one on your machine.

Please keep me posted.
Cheers,

Alon Sapozhnikov
Support Specialist.

answered by Alon_TypeMock (6.6k points)
selected by Alon_TypeMock
...