chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes

When run from TeamCity, I am getting the following error when running unit tests that use typemock: [12:25:38]

[VSTest] PlateTech.Agent.Test.AgentInterface_Operations.RejectionResponseReasonList_Test.RejectionResponseReasons_are_properly_converted_to_json
[12:25:38][PlateTech.Agent.Test.AgentInterface_Operations.RejectionResponseReasonList_Test.RejectionResponseReasons_are_properly_converted_to_json] Test method PlateTech.Agent.Test.AgentInterface_Operations.RejectionResponseReasonList_Test.RejectionResponseReasons_are_properly_converted_to_json threw exception: TypeMock.TypeMockException: *** Typemock Isolator is currently disabled. Enable using the following: * Within Visual Studio: - Use Typemock Smart Runner - For other runners, Choose Typemock Menu and click "Integrate with Other Runners" * To run Typemock Isolator as part of an automated process you can: - run tests via TMockRunner.exe command line tool - use 'TypeMockStart' tasks for MSBuild or NAnt For more information consult the documentation (see 'Running Unit Tests in an Automated Build')

 I have followed the the Server Insallation steps outlined here (http://www.typemock.com/docs/?book=Isolator&page=Documentation%2FHtmlDocs%2Fautodeploy.htm) and here: http://www.typemock.com/docs/?book=Isolator&page=Documentation%2FHtmlDocs%2FBestPractices.htm#ReferencingTypemockBestPractice)

I have also added the "Register Type Mock" task to the Test.csproj

Also I have tried the solution outlined here (https://stackoverflow.com/questions/19005376/getting-teamcity-to-run-unit-tests-using-typemock)

But I still have approximately 100 tests failing. All are Typemock tests. 

All of these tests pass when run locally.

Help!

asked by Mark (3.1k points)

1 Answer

0 votes
Hi Mark,

It is not so clear which steps were made in your TC build pipeline and which particular tests\ or all of them are failing on run,

Please open a ticket in our support system and provide us with all information and logs so the issue could be investigated, I am sure it will be easy to fix!

Thanks :)
answered by David (1.9k points)
...