chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Community! Here you can ask and receive answers from other community members. If you liked or disliked an answer or thread: react with an up- or downvote.
+1 vote

I have installed Typemock Version 8.6 with Visual studio 2017.

The problem is that I can run tests successfully in VS2017, but cannot debug them.  When trying to debug, I get an exception in UnitTestSupport when calling the FakeSupport constructor in the TestInitialize method.  The exception is:
{\"\\r\\n*** Typemock Isolator is currently disabled. Enable using the following:\\r\\n\\r\\n * Within Visual Studio: \\r\\n   - Use Typemock Smart Runner  \\r\\n   - For other runners, Choose Typemock Menu and click \\\"Integrate with Other Runners\\\"\\r\\n \\r\\n * To run Typemock Isolator as part of an automated process you can:\\r\\n    - run tests via TMockRunner.exe command line tool\\r\\n    - use \'TypeMockStart\' tasks for MSBuild or NAnt\\r\\n \\r\\nFor more information consult the documentation (see \'Running Unit Tests in an Automated Build\')\"}

\"Integrate with Other Runners\" is enabled.  I have tried with Smart Runner enabled and disabled.  

FYI...I can debug same test successfully in VS2013. Please help us to resolve this issue.

asked by satanova81 (4.2k points)

1 Answer

0 votes

This looks like a bug.

Can you please tell us how do you start debugging your tests? Via \"Debug\" tab or by pressing right-mouse-button on the test and \"Debug This Test, Break Here\"?

answered by Raphy (4k points)
We are using by pressing right-mouse button on the test and \"debug test\" option.
I\'m using Typemock
Do I have any update on this?

Please try debugging by pressing the right-mouse-key and then  \"Debug This Test, Break Here\". 

I tried debugging by using right mouse button and then debug this test. Still I\'m not able to debug the test code.
Any update on this ticket?