chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Community! Here you can ask and receive answers from other community members. If you liked or disliked an answer or thread: react with an up- or downvote.
0 votes
Hi all,
I'm writing a custom VS2005 addin to execute my tests, but I found the following problem. Whenever a test method is executed, I received the following error:

*** Typemock Isolator needs to be linked with Coverage Tool to run, to enable do one of the following:
   1. link the Coverage tool through the Typemock Isolator Configuration
   2. run tests via TMockRunner.exe -link
   3. use TypeMockStart tasks for MSBuild or NAnt with Link 
For more information consult the documentation (see Code Coverage with Typemock Isolator topic)
   at TypeMock.MockManager.Init(Boolean collectAllCalls)
   at TypeMock.MockManager.e(Type A_0)
   at TypeMock.MockManager.Mock(Type type, Constructor mockConstructors)
   at TypeMock.MockManager.Mock(Type type)
   at TestExample.Class1.Test()


Please note that Typemock Isolator (v4.3.1) is enabled. What is required in order to properly activate TypeMock?

Thanks
asked by (4.7k points)

3 Answers

0 votes
Hi Deimos,

I think it has to do with the way you run your tests. Perhaps you should run it with TMockRunner.
How do you start your runner? can you post the command line you're running?

Thanks
answered by (14.5k points)
0 votes
Hi Gilz,
sorry I forgot to mention that the runner is included directly in the addin (test methods are executed by reflection), rather than launching it as an external process.

Thanks
answered by (4.7k points)
0 votes
Hi Deimos,

Let's take it offline. This is something we'll need to check in our labs. I'll write a separate email.

Thanks,
answered by (14.5k points)
...